[PATCH 3/5] gnu: Add libpepadapter.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hartmut Goebel
  • Hartmut Goebel
Owner
unassigned
Submitted by
Hartmut Goebel
Severity
normal
H
H
Hartmut Goebel wrote on 23 May 2020 10:58
8e4b80a510d1cea849ef68364a912fe51824bb42.1590224092.git.h.goebel@crazy-compilers.com
* gnu/packages/pep.scm (libpepadapter): New variable.
---
gnu/packages/pep.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/pep.scm b/gnu/packages/pep.scm
index d69e1a3929..c101ab4fb4 100644
--- a/gnu/packages/pep.scm
+++ b/gnu/packages/pep.scm
@@ -152,3 +152,44 @@ OPENPGP=SEQUOIA
privacy).")
(license ;; code: GPL 3, docs: CC-BY-SA
(list license:gpl3 license:cc-by-sa3.0))))
+
+(define-public libpepadapter
+ (package
+ (name "libpepadapter")
+ (version "2.0.2")
+ (source
+ (origin
+ (method hg-fetch)
+ (uri (hg-reference
+ (url "https://pep.foundation/dev/repos/libpEpAdapter")
+ (changeset "e8fe371c870a"))) ;; r168
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32 "1mlpavjbnmslvmr5jxcvpjgb2x40nhmxjb10hza3kn4qzj0k1pjz"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:test-target "test"
+ #:tests? #f ;; building the tests fails
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ ;; libpEpAdapter does not use autotools and configure,
+ ;; but a local.conf. We need to tweak the values there.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (engine (assoc-ref inputs "pep-engine")))
+ (with-output-to-file "local.conf"
+ (lambda _ ;()
+ (format #t "
+PREFIX=~a
+ENGINE_LIB_PATH=~a/lib
+ENGINE_INC_PATH=~a/include
+" out engine engine))))
+ #t)))))
+ (inputs
+ `(("pep-engine" ,pep-engine)))
+ (home-page "https://pep.foundation/")
+ (synopsis "Library for building p≡p adapters")
+ (description "This C++ library provides common structures used in p≡p
+adapters.")
+ (license license:bsd-3)))
--
2.21.3
H
?