[PATCH] gnu: Add mspdebug.

  • Done
  • quality assurance status badge
Details
3 participants
  • Morgan.J.Smith
  • Marius Bakke
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal
M
M
Morgan.J.Smith wrote on 27 May 2020 19:34
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR1001MB2105C89D713D8507F978DC08C5B10@DM5PR1001MB2105.namprd10.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/mspdebug.scm (mspdebug): New variable.
---
gnu/packages/mspdebug.scm | 44 +++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)
create mode 100644 gnu/packages/mspdebug.scm

Toggle diff (52 lines)
diff --git a/gnu/packages/mspdebug.scm b/gnu/packages/mspdebug.scm
new file mode 100644
index 0000000000..fcabcae472
--- /dev/null
+++ b/gnu/packages/mspdebug.scm
@@ -0,0 +1,44 @@
+;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
+
+(define-module (gnu packages mspdebug)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix licenses)
+ #:use-module (gnu packages libusb)
+ #:use-module (gnu packages readline))
+
+
+(define-public mspdebug
+ (package
+ (name "mspdebug")
+ (version "0.25")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dlbeer/mspdebug.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0prgwb5vx6fd4bj12ss1bbb6axj2kjyriyjxqrzd58s5jyyy8d3c"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases (delete 'configure) (delete 'check))
+ #:make-flags
+ (let ((target ,(%current-target-system)))
+ (list (string-append "CC=" (if target
+ (string-append target "-gcc")
+ "gcc"))
+ "INSTALL=install"
+ (string-append "PREFIX=" %output)))))
+ (inputs
+ `(("libusb-compat" ,libusb-compat)
+ ("readline" ,readline)))
+ (synopsis "Free debugger for use with MSP430 MCUs")
+ (description "MspDebug supports FET430UIF, eZ430, RF2500 and Olimex
+MSP430-JTAG-TINY programmers, as well as many other compatible
+devices. It can be used as a proxy for gdb or as an independent
+debugger with support for programming, disassembly and reverse
+engineering.")
+ (home-page "https://github.com/dlbeer/mspdebug")
+ (license gpl2)))
--
2.26.2
M
M
Marius Bakke wrote on 30 May 2020 15:53
(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
87wo4tzfzk.fsf@gnu.org
Morgan.J.Smith@outlook.com writes:

Toggle quote (4 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/mspdebug.scm (mspdebug): New variable.

Can you move this package to gnu/packages/debug.scm instead of adding a
new module?

[...]

Toggle quote (21 lines)
> +(define-public mspdebug
> + (package
> + (name "mspdebug")
> + (version "0.25")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/dlbeer/mspdebug.git")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "0prgwb5vx6fd4bj12ss1bbb6axj2kjyriyjxqrzd58s5jyyy8d3c"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:phases (modify-phases %standard-phases (delete 'configure) (delete 'check))
> + #:make-flags
> + (let ((target ,(%current-target-system)))
> + (list (string-append "CC=" (if target
> + (string-append target "-gcc")
> + "gcc"))

Since very recently, you can now use:

(string-append "CC=" ,(cc-for-target))

instead of the let binding and conditional.

Toggle quote (7 lines)
> + "INSTALL=install"
> + (string-append "PREFIX=" %output)))))
> + (inputs
> + `(("libusb-compat" ,libusb-compat)
> + ("readline" ,readline)))
> + (synopsis "Free debugger for use with MSP430 MCUs")

No need to mention free here, since everything in Guix is free
software. The GitHub tagline is pretty good:

Debugging tool for MSP430 MCUs

Toggle quote (8 lines)
> + (description "MspDebug supports FET430UIF, eZ430, RF2500 and Olimex
> +MSP430-JTAG-TINY programmers, as well as many other compatible
> +devices. It can be used as a proxy for gdb or as an independent
> +debugger with support for programming, disassembly and reverse
> +engineering.")
> + (home-page "https://github.com/dlbeer/mspdebug")
> + (license gpl2)))

This should be 'gpl2+', since the source files say "GPL 2 or any later
version".

Can you send an updated patch? Thanks in advance!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7SZU8ACgkQoqBt8qM6
VPoWhwf/eTDiIu5QQMDAGCZ0+JRIR3DCF8zuyj+w/RayLjz4HcH3ORfg7RoIcWgx
EnR1q9ajjh17Qi3bx+j4P1d8TsGRJDcs5Ggx6HGG+ZTdTtvylI1YxNCcvX476cv8
7guMTbPGoAJcgqy7JMaqiPFGYaTDP6vnfixVeBdybW0XJ491ptgkGvJPSc1/X5zB
GOQwwgATXrDNFJBXxsi7ewekAB32jRGcEOCN9xsRd5/VyQ00hDM6+UWMcfG8yetD
U3MVpLVApJSDLx0Hnka7sHdu6DC8JbPvXWoiVBL324ZN3TpP3UG8uUc3v3P9gkjT
jOqhBKLPCuZjkOANNXbtxCdA9a8ciA==
=bavB
-----END PGP SIGNATURE-----

T
T
Tobias Geerinckx-Rice wrote on 30 May 2020 21:03
(address . Morgan.J.Smith@outlook.com)(address . 41567@debbugs.gnu.org)
874krx1c06.fsf@nckx
Morgan,

Morgan.J.Smith@outlook.com ???
Toggle quote (3 lines)
> + `(#:phases (modify-phases %standard-phases (delete
> 'configure) (delete 'check))

Try to keep lines within 80 characters. Have you heard of our
lord & saviour ‘guix lint’? It's nitpicking like this, automated.

There's a more ‘declarative’ way to disable tests. Add a short
note why:

`(#:tests? #f ; no test suite
#:phases
(modify-phases %standard-phases
(delete 'configure))) ; no configure script

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXtKt+QAKCRANsP+IT1Vt
eY07AQDHiquGatpR1aI0ItjuKMXFy3aCnbOtdS1bXjDs/+uYXQD+PaB2cStBR6FU
28ZU0K+ita3cHPkc9HQWFP/CKPaD8g4=
=Btwt
-----END PGP SIGNATURE-----

M
M
Morgan.J.Smith wrote on 30 May 2020 22:33
[PATCH] gnu: Add mspdebug.
(address . 41567@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR1001MB210564177165268B2BEB2789C58C0@DM5PR1001MB2105.namprd10.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/debug.scm (mspdebug): New variable.
---
gnu/packages/debug.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 4a264427c2..18cc2894a7 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -56,6 +57,7 @@
#:use-module (gnu packages serialization)
#:use-module (gnu packages virtualization)
#:use-module (gnu packages xdisorg)
+ #:use-module (gnu packages libusb)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
@@ -596,3 +598,37 @@ GDB with very efficient reverse-execution, which in combination with standard
GDB/x86 features like hardware data watchpoints, makes debugging much more
fun.")
(license license:expat)))
+
+(define-public mspdebug
+ (package
+ (name "mspdebug")
+ (version "0.25")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dlbeer/mspdebug.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0prgwb5vx6fd4bj12ss1bbb6axj2kjyriyjxqrzd58s5jyyy8d3c"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)) ; no configure script
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ "INSTALL=install"
+ (string-append "PREFIX=" %output))))
+ (inputs
+ `(("libusb-compat" ,libusb-compat)
+ ("readline" ,readline)))
+ (synopsis "Debugging tool for MSP430 MCUs")
+ (description "MspDebug supports FET430UIF, eZ430, RF2500 and Olimex
+MSP430-JTAG-TINY programmers, as well as many other compatible
+devices. It can be used as a proxy for gdb or as an independent
+debugger with support for programming, disassembly and reverse
+engineering.")
+ (home-page "https://github.com/dlbeer/mspdebug")
+ (license license:gpl2+)))
--
2.26.2
M
M
Marius Bakke wrote on 30 May 2020 23:18
(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
878sh9xgsp.fsf@gnu.org
Morgan.J.Smith@outlook.com writes:

Toggle quote (4 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/debug.scm (mspdebug): New variable.

Applied, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7SzbYACgkQoqBt8qM6
VPohwQf+KDfTnipI01PQisLbfXSIXT7Jl7MybewO1dkXAyHTCM0QBj/WJGCNn/PI
n1GdzI9anuUUFim4u6d07ldY11JvFycFjfmRWV+MzIbk7YItn9eRcWLqstVLPKMR
WhT9k9SacnyAR+WSQY+7xX3kneM3AvpKuOqz00qYgyFcV4WuNy0gqIXH35zVC77P
60W50hIblGWhwj6RPZqEN2xnUFEMS62nbstOuXke0U9awh2aeUPEJvolG2J5/piN
U/lXOev45vicQmGudhQhwfqQuPrwlR1avk7VCEQlzi2GIeklVX2xtSvw9NO+zu6r
rSn6Mpa7T7AhHXGIIOXFJIpwApMPOQ==
=hEQy
-----END PGP SIGNATURE-----

Closed
?