[PATCH] gnu: Add bbswitch-module.

  • Done
  • quality assurance status badge
Details
2 participants
  • Pierre Neidhardt
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Pierre Neidhardt
Severity
normal
P
P
Pierre Neidhardt wrote on 11 Jun 2020 22:24
(address . guix-patches@gnu.org)
20200611202423.9284-1-mail@ambrevar.xyz
* gnu/packages/linux.scm (bbswitch-module): New variable.
---
gnu/packages/linux.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 73d99be48c..7c19517432 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1137,6 +1137,29 @@ network adapters.")
between the CDemu userspace daemon and linux kernel.")
(license license:gpl2+)))
+(define-public bbswitch-module
+ (package
+ (name "bbswitch-module")
+ (version "0.8")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Bumblebee-Project/bbswitch")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1glch4j0x1dzlp2yrb67v2r5jg9609jb6p8m251y78m74advqw0l"))))
+ (build-system linux-module-build-system)
+ (arguments
+ ;; No tests.
+ `(#:tests? #f))
+ (home-page "https://github.com/Bumblebee-Project/bbswitch")
+ (synopsis "Kernel module that disables discrete Nvidia graphics cards")
+ (description "The bbswitch module provides a way to toggle the Nvidia
+graphics card on Optimus laptops.")
+ (license license:gpl2)))
+
(define-public ddcci-driver-linux
(package
(name "ddcci-driver-linux")
--
2.26.2
M
M
Mathieu Othacehe wrote on 14 Jun 2020 12:05
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 41813@debbugs.gnu.org)
87eeqiklmu.fsf@gnu.org
Hello Pierre,

Toggle quote (4 lines)
> + (synopsis "Kernel module that disables discrete Nvidia graphics cards")
> + (description "The bbswitch module provides a way to toggle the Nvidia
> +graphics card on Optimus laptops.")

The home page says that's it's intended to disable discrete graphics,
but only working with Nvidia currently. Maybe you should add this
information?

Otherwise, this looks good to me.

Thanks,

Mathieu
P
P
Pierre Neidhardt wrote on 14 Jun 2020 12:27
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 41813@debbugs.gnu.org)
87a716nds0.fsf@ambrevar.xyz
Mathieu Othacehe <othacehe@gnu.org> writes:

Toggle quote (10 lines)
> Hello Pierre,
>
>> + (synopsis "Kernel module that disables discrete Nvidia graphics cards")
>> + (description "The bbswitch module provides a way to toggle the Nvidia
>> +graphics card on Optimus laptops.")
>
> The home page says that's it's intended to disable discrete graphics,
> but only working with Nvidia currently. Maybe you should add this
> information?

Sorry, I'm not sure what you mean :) Are you saying that I should
mention that it could potentially work with any brand in the future?
Considering the age of the last commit, I doubt it ever will :)

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl7l+38ACgkQm9z0l6S7
zH8Gsgf/S4Rp4T0VFPjIXOARN2csC+2S1m2YiynaPtTNtzTlLYMMqB/artjjV3YN
JDU3nrvjDfC6/cg/Wn4U5u+YkApTBzrVZG+nf3nwIncut4miECboiwqxJb5LUJXD
FGrdRCzvIli4fupYU4PhfXBHd51h/p9nAfilkef8OcvmywmvhFpMlmpmZQUv2HgP
ptQWbzPLKkdW/u8b8hI49AIgWy41JjXaW/t8WFz8D6CtRa9Ceki2VjokYr4sivhS
R355AjOheESbYMKzKLoGXgy5ePln7kLcdka/REDf2oyAi9lmJb8h1Iszu52tPOD9
r/AgYEknjeX4Qpp+T/GC96p1DTfi1w==
=a5xX
-----END PGP SIGNATURE-----

M
M
Mathieu Othacehe wrote on 14 Jun 2020 12:42
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 41813@debbugs.gnu.org)
87r1uij5d9.fsf@gnu.org
Toggle quote (4 lines)
> Sorry, I'm not sure what you mean :) Are you saying that I should
> mention that it could potentially work with any brand in the future?
> Considering the age of the last commit, I doubt it ever will :)

Yes, mmh, '2013' then I guess you're right.

Mathieu
P
P
Pierre Neidhardt wrote on 14 Jun 2020 13:26
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 41813@debbugs.gnu.org)
877dw9oplg.fsf@ambrevar.xyz
Thanks, merged.

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl7mCWsACgkQm9z0l6S7
zH8RWAf9HGRADsK80l2fWKkZp+vqvydoa6haqEwytFsTQc7vzWb5pIgFuF5NM2ZV
crwWaSPba0qmoiFJNjqB11fp1vuooj3IJNOyI0321XYbxTkz2POioMdd5FO0RJ0+
/0wV6tyGct8+31ZIN7CHmUpe/Sgp1vRjHpz1UL6gQtlyssAk0B0UDerDSzbiO+O3
gnWhWgs6viu60TbBufgMm/u+2/zmmk6dTFuWnss4Y3FlagxNYpWboga60qnkkDqT
yYvYY80IuOaD0PL3vQumTUKSeEkV4J8WkYg2Pm6LwWUe7izQb/+pwRK4POlc+fUm
+arArZ5N0GIdDnjMJ6FtKrJcn8Z7kA==
=iWQh
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 14 Jun 2020 13:27
control message for bug #41813
(address . control@debbugs.gnu.org)
875zbtopkn.fsf@ambrevar.xyz
close 41813
quit
?