'--with-input', '--with-git-url' etc. cause unnecessary rebuilds

DoneSubmitted by pkill9.
Details
2 participants
  • Ludovic Courtès
  • pkill9
Owner
unassigned
Severity
important
Merged with
P
P
pkill9 wrote on 1 Jul 19:04 +0200
Guix unnecessarily rebuilds packages when replacing a source with --with-git-url
(address . bug-guix@gnu.org)
20200701180412.00e2686c@runbox.com
Running `guix build --with-git-url=youtube-dl=https://github.com/ytdl-org/youtube-dlmpv -n`shows it will rebuild packages unecessarily:
```The following derivations would be built: /gnu/store/3qhfgkacylwsvzxgz5fqdgxlx812c7nf-mpv-0.32.0.drv /gnu/store/2240y6fjiq2riiq1rj4apci5s7sl7rk6-youtube-dl-2020.06.16.1.drv /gnu/store/94dqd7xiy0sdmhzxikqrycllm921fcm5-libcaca-0.99.beta19.drv /gnu/store/r0p4y6b78x2lfdh51p8287al3i461pfr-ftgl-2.4.0.drv /gnu/store/an06c6fg9w0ja44sbmnssryklziyjsia-mpg123-1.26.1.drv /gnu/store/ddkwx46ksizbz59fc5xwfxb7bq5j246h-ffmpeg-4.3.drv /gnu/store/h28qpl97rs3fc2rc2n2vxcpy3pyxnbm8-frei0r-plugins-1.7.0.drv /gnu/store/nyk555wa6kjqz311ini6gji21vl9j6lz-sdl2-2.0.12.drv /gnu/store/5mh046xgl3qzdkmccvmi3g08cl2zh4g0-fcitx-4.2.9.7.drv /gnu/store/jxqzag3jb5jbj5z60md011gi4r6g97js-enchant-1.6.0.drv /gnu/store/mi4ris95502ixx7yybp8wxay4g53q0zn-ibus-1.5.22.drv /gnu/store/3vhw2hspgvskfq26zsk2iihjlavp16id-dconf-0.34.0.drv /gnu/store/aybh2nafr8v5k8w1ld28s1hzvg3mfjkg-libnotify-0.7.7.drv /gnu/store/jzxixdnm7cbfajfx901mypi1acidjj0i-orbit2-2.14.19.drv /gnu/store/cwm9rdd3c1l6j2x3gdkc6s8dxaba9hfb-libidl-0.8.14.drv /gnu/store/rams8llip6qlhw1w83sl7xmamy52fr68-gconf-3.2.6.drv /gnu/store/3s2isd4z1qzyansngg67ib0a5hswvjs0-dbus-glib-0.110.drv /gnu/store/pv6a3vfay83kzcszl0rcnv0d5v1v1cd7-openal-1.20.1.drv /gnu/store/ynpm7jd13yyciz2lpyr6q9rh2kx0g530-libass-0.14.0.drv /gnu/store/yyc2cqz28nh75h1zgvjsza2w1nkxn8ai-libva-2.7.1.drv /gnu/store/gh57iyp68zjs0xfwfcfp6a3jsshpgp2j-rsound-1.1.drv /gnu/store/hj1s2riv7zvyvmw1hbnzzkv2gfa0ncqn-ao-1.2.2-5-g20dc8ed.drv /gnu/store/k0g5pp30s1m32yii5fk9rbiy2h3jyjhy-vulkan-loader-1.2.140.drv```
It can be seen that it's unnecessary by running `guix graph --pathyoutube-dl ffmpeg` and it shows youtube-dl isn't in the package graphfor ffmpeg, yet it's still rebuilding it.
L
L
Ludovic Courtès wrote on 2 Jul 00:14 +0200
control message for bug #38100
(address . control@debbugs.gnu.org)
878sg2yjbj.fsf@gnu.org
merge 38100 42156quit
L
L
Ludovic Courtès wrote on 2 Jul 00:14 +0200
Re: bug#42156: Guix unnecessarily rebuilds packages when replacing a source with --with-git-url
(name . pkill9)(address . pkill9@runbox.com)(address . 42156@debbugs.gnu.org)
874kqqyja8.fsf@gnu.org
pkill9 <pkill9@runbox.com> skribis:
Toggle quote (3 lines)> Running `guix build --with-git-url=youtube-dl=https://github.com/ytdl-org/youtube-dlmpv -n`> shows it will rebuild packages unecessarily:
Merged with https://issues.guix.gnu.org/38100.
Thanks,Ludo’.
L
L
Ludovic Courtès wrote on 2 Jul 00:15 +0200
control message for bug #38100
(address . control@debbugs.gnu.org)
87zh8ix4o8.fsf@gnu.org
severity 38100 importantquit
L
L
Ludovic Courtès wrote on 3 Aug 16:30 +0200
control message for bug #42156
(address . control@debbugs.gnu.org)
87tuxjssyb.fsf@gnu.org
retitle 42156 '--with-input', '--with-git-url' etc. cause unnecessary rebuildsquit
?