[PATCH] gnu: add sbcl-xmls

  • Done
  • quality assurance status badge
Details
3 participants
  • Guillaume Le Vaillant
  • Leo Famulari
  • Adam Kandur
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
A
A
Adam Kandur wrote on 12 Aug 2020 08:46
(name . Guix Patches)(address . guix-patches@gnu.org)
MEWPmve--3-2@tuta.io

From ad2cdcd9fbd463643b38be0aafb4b64e31c9ab09 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Wed, 12 Aug 2020 09:41:59 +0300
Subject: [PATCH] gnu: Add sbcl-xmls.

* gnu/packages/lisp-xyz.scm (sbcl-xmls): New variable.
---
gnu/packages/lisp-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b8216b0..7c0be15 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13509,3 +13509,33 @@ for an example.")
(define-public ecl-hu.dwim.defclass-star
(sbcl-package->ecl-package sbcl-hu.dwim.defclass-star))
+
+(define-public sbcl-xmls
+ (let ((commit "18546f0850b1338e03997ffd1696add1cb1800d1")
+ (revision "1"))
+ (package
+ (name "sbcl-xmls")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rpgoldman/xmls")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lmvfml2ldbb1wkhm25jqqk2bhwsz52hhcgljbnzj1xr8xhc3anp"))))
+ (inputs
+ `(("fiveam" ,sbcl-fiveam)))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/rpgoldman/xmls")
+ (synopsis "Xmls is a small, simple, non-validating xml parser for Common Lisp.")
+ (description "Xmls designed to be a self-contained, easily embedded parser that recognizes a useful subset of the XML spec.
+It provides a simple mapping from xml to lisp structures or s-expressions and back.")
+ (license license:bsd-2))))
+
+(define-public cl-xmls
+ (sbcl-package->cl-source-package sbcl-xmls))
+
+(define-public ecl-xmls
+ (sbcl-package->ecl-package sbcl-xmls))
--
2.28.0
L
L
Leo Famulari wrote on 22 Aug 2020 20:58
(name . Adam Kandur via Guix-patches via)(address . guix-patches@gnu.org)(address . 42821@debbugs.gnu.org)
20200822185857.GB20524@jasmine.lan
Toggle quote (7 lines)
> From ad2cdcd9fbd463643b38be0aafb4b64e31c9ab09 Mon Sep 17 00:00:00 2001
> From: Adam Kandur <rndd@tuta.io>
> Date: Wed, 12 Aug 2020 09:41:59 +0300
> Subject: [PATCH] gnu: Add sbcl-xmls.
>
> * gnu/packages/lisp-xyz.scm (sbcl-xmls): New variable.

Thanks! Please make sure the commit message mentions all the new
variables.

Toggle quote (3 lines)
> + (inputs
> + `(("fiveam" ,sbcl-fiveam)))

I noticed that the built package does not keep a reference to
sbcl-fiveam. Is that expect for SBCL packages? Is it just for
build-time?

Toggle quote (2 lines)
> + (license license:bsd-2))))

The COPYING file contains a 3-clause BSD license.

Can you look into the fiveam issue and submit a revised patch?
G
G
Guillaume Le Vaillant wrote on 29 Nov 2020 16:44
(name . Adam Kandur)(address . rndd@tuta.io)
87a6v0b21i.fsf@yamatai
This was fixed by commit 7722c367bc007ca979bc7cb16e135c7ac0b864ed.
Closing.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCX8PB6Q8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9WEgD/fSaOmtgosIlfM5/aFtK8wTXeWyLfBNj2OOj/
/hRSbfcA+wYz+SUUr2Uf9dGNADJVwYr1hf7TiE3YSQvZqARDHziK
=94ie
-----END PGP SIGNATURE-----

Closed
?