[PATCH 1/6] gnu: Add spglib.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Leo Famulari
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal
K
K
Kei Kebreau wrote on 25 Jan 2021 22:20
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20210125212042.4358-1-kkebreau@posteo.net
* gnu/packages/chemistry.scm (spglib): New variable.
---
gnu/packages/chemistry.scm | 45 ++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index ddbf5ca098..7a9b3069fa 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -29,6 +29,7 @@
#:use-module (guix git-download)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -464,3 +465,47 @@ chemical data. It's a collaborative project allowing anyone to search, convert,
analyze, or store data from molecular modeling, chemistry, solid-state
materials, biochemistry, or related areas.")
(license license:gpl2)))
+
+(define-public spglib
+ (package
+ (name "spglib")
+ (version "1.16.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/spglib/spglib")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1kzc956m1pnazhz52vspqridlw72wd8x5l3dsilpdxl491aa2nws"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (arguments
+ '(#:test-target "check"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ ;; These files are required by the Makefile, but not provided by
+ ;; the developers.
+ (for-each (lambda (file) (invoke "touch" file))
+ '("NEWS" "README" "AUTHORS"))
+ (invoke "autoreconf" "-vi"))))))
+ (home-page "https://spglib.github.io/spglib/index.html")
+ (synopsis "Library for crystal symmetry search")
+ (description "Spglib is a library for finding and handling crystal
+symmetries written in C. Spglib can be used to:
+
+@enumerate
+@item Find symmetry operations
+@item Identify space-group type
+@item Wyckoff position assignment
+@item Refine crystal structure
+@item Find a primitive cell
+@item Search irreducible k-points
+@end enumerate")
+ (license license:bsd-3)))
--
2.29.2
K
K
Kei Kebreau wrote on 25 Jan 2021 22:22
[PATCH 2/6] gnu: Add mmtf-cpp.
(address . 46107@debbugs.gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20210125212248.4749-1-kkebreau@posteo.net
* gnu/packages/chemistry.scm (mmtf-cpp): New variable.
---
gnu/packages/chemistry.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 7a9b3069fa..4ac7a90c87 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -242,6 +242,31 @@ analogy is that InChI is the bar-code for chemistry and chemical structures.")
"file://LICENCE"
"See LICENCE in the distribution."))))
+(define-public mmtf-cpp
+ (package
+ (name "mmtf-cpp")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rcsb/mmtf-cpp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17ylramda69plf5w0v5hxbl4ggkdi5s15z55cv0pljl12yvyva8l"))))
+ (build-system cmake-build-system)
+ ;; Tests require the soon-to-be-deprecated version 1 of the catch-framework.
+ (arguments
+ '(#:tests? #f))
+ (home-page "https://mmtf.rcsb.org/")
+ (synopsis "C++ API for the Macromolecular Transmission Format")
+ (description "This package is a library for the
+@acronym{MMTF,macromolecular transmission format}, a binary encoding of
+biological structures.")
+ (license license:expat)))
+
(define with-numpy-1.8
(package-input-rewriting `((,python2-numpy . ,python2-numpy-1.8))))
--
2.29.2
K
K
Kei Kebreau wrote on 25 Jan 2021 22:22
[PATCH 3/6] gnu: Add molequeue.
(address . 46107@debbugs.gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20210125212248.4749-2-kkebreau@posteo.net
* gnu/packages/chemistry.scm (molequeue): New variable.
---
gnu/packages/chemistry.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 4ac7a90c87..2b54df564e 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -267,6 +267,35 @@ analogy is that InChI is the bar-code for chemistry and chemical structures.")
biological structures.")
(license license:expat)))
+(define-public molequeue
+ (package
+ (name "molequeue")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/OpenChemistry/molequeue/"
+ "releases/download/" version "/molequeue-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1w1fgxzqrb5yxvpmnc3c9ymnvixy0z1nfafkd9whg9zw8nbgl998"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("qtbase" ,qtbase)))
+ ;; TODO: Enable tests.
+ (arguments
+ '(#:tests? #f))
+ (home-page "https://www.openchemistry.org/projects/molequeue/")
+ (synopsis "Application for coordinating computational jobs")
+ (description "MoleQueue is a system-tray resident desktop application for
+abstracting, managing, and coordinating the execution of tasks both locally and
+ on remote computational resources. Users can set up local and remote queues
+that describe where the task will be executed. Each queue can have programs,
+with templates to facilitate the execution of the program. Input files can be
+staged, and output files collected using a standard interface.")
+ (license license:bsd-3)))
+
(define with-numpy-1.8
(package-input-rewriting `((,python2-numpy . ,python2-numpy-1.8))))
--
2.29.2
K
K
Kei Kebreau wrote on 25 Jan 2021 22:22
[PATCH 4/6] gnu: Add libmsym.
(address . 46107@debbugs.gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20210125212248.4749-3-kkebreau@posteo.net
* gnu/packages/chemistry.scm (libmsym): New variable.
---
gnu/packages/chemistry.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 2b54df564e..73aed08d43 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -242,6 +242,30 @@ analogy is that InChI is the bar-code for chemistry and chemical structures.")
"file://LICENCE"
"See LICENCE in the distribution."))))
+(define-public libmsym
+ (package
+ (name "libmsym")
+ (version "0.2.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mcodev31/libmsym")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0a9j28irdsr461qpzlc9z1yjyb9kp64fh5zw7ylspc9zn3189qwk"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")
+ #:tests? #f)) ; no check target
+ (home-page "https://github.com/mcodev31/libmsym")
+ (synopsis "C library dealing with point group symmetry in molecules")
+ (description "libmsym is a C library dealing with point group symmetry in
+molecules.")
+ (license license:expat)))
+
(define-public mmtf-cpp
(package
(name "mmtf-cpp")
--
2.29.2
K
K
Kei Kebreau wrote on 25 Jan 2021 22:22
[PATCH 5/6] gnu: Add avogadrolibs.
(address . 46107@debbugs.gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20210125212248.4749-4-kkebreau@posteo.net
* gnu/packages/chemistry.scm (avogadrolibs): New variable.
---
gnu/packages/chemistry.scm | 44 ++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (71 lines)
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 73aed08d43..9d4c6f07fa 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -30,6 +30,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages backup)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -44,6 +45,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages serialization)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages xml)
#:use-module (guix build-system cmake)
@@ -135,6 +137,48 @@ science, and related areas. It offers flexible high quality rendering and a
powerful plugin architecture.")
(license license:gpl2+)))
+(define-public avogadrolibs
+ (package
+ (name "avogadrolibs")
+ (version "1.93.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenChemistry/avogadrolibs")
+ (commit version)))
+ (sha256
+ (base32 "1xivga626n5acnmwmym8svl0pdri8hkp59czf04ri2zflnviyh39"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("eigen" ,eigen)
+ ("mmtf-cpp" ,mmtf-cpp)
+ ("msgpack" ,msgpack)
+ ("googletest" ,googletest)
+ ("pkg-config" ,pkg-config)
+ ("pybind11" ,pybind11)))
+ (inputs
+ `(("glew" ,glew)
+ ("libarchive" ,libarchive)
+ ("libmsym" ,libmsym)
+ ("molequeue" ,molequeue)
+ ("python" ,python)
+ ("spglib" ,spglib)
+ ("qtbase" ,qtbase)))
+ (arguments
+ '(#:configure-flags (list "-DENABLE_TESTING=ON"
+ (string-append "-DSPGLIB_INCLUDE_DIR="
+ (assoc-ref %build-inputs "spglib")
+ "/include"))))
+ (home-page "https://www.openchemistry.org/projects/avogadro2/")
+ (synopsis "Libraries for chemistry, bioinformatics, and related areas")
+ (description
+ "Avogadro libraries provide 3D rendering, visualization, analysis and data
+processing useful in computational chemistry, molecular modeling,
+bioinformatics, materials science, and related areas.")
+ (license license:bsd-3)))
+
(define-public domainfinder
(package
(name "domainfinder")
--
2.29.2
K
K
Kei Kebreau wrote on 25 Jan 2021 22:22
[PATCH 6/6] gnu: Add avogadro2.
(address . 46107@debbugs.gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20210125212248.4749-5-kkebreau@posteo.net
* gnu/packages/chemistry.scm (avogadro2): New variable.
---
gnu/packages/chemistry.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 9d4c6f07fa..8fe51d79ee 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -179,6 +179,41 @@ processing useful in computational chemistry, molecular modeling,
bioinformatics, materials science, and related areas.")
(license license:bsd-3)))
+(define-public avogadro2
+ (package
+ (name "avogadro2")
+ (version "1.93.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenChemistry/avogadroapp")
+ (commit version)))
+ (sha256
+ (base32
+ "1z3pjlwja778a1dmvx9aqz2hlw5q9g3kqxhm9slz08452600jsv7"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("eigen" ,eigen)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("avogadrolibs" ,avogadrolibs)
+ ("hdf5" ,hdf5)
+ ("molequeue" ,molequeue)
+ ("qtbase" ,qtbase)))
+ ;; TODO: Enable tests with "-DENABLE_TESTING" configure flag.
+ (arguments
+ '(#:tests? #f))
+ (home-page "https://www.openchemistry.org/projects/avogadro2/")
+ (synopsis "Advanced molecule editor")
+ (description
+ "Avogadro 2 is an advanced molecule editor and visualizer designed for use
+in computational chemistry, molecular modeling, bioinformatics, materials
+science, and related areas. It offers flexible high quality rendering and a
+powerful plugin architecture.")
+ (license license:bsd-3)))
+
(define-public domainfinder
(package
(name "domainfinder")
--
2.29.2
L
L
Leo Famulari wrote on 25 Jan 2021 23:17
Re: [bug#46107] [PATCH 1/6] gnu: Add spglib.
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 46107@debbugs.gnu.org)
YA9Dk9wdYLAV7OAk@jasmine.lan
On Mon, Jan 25, 2021 at 04:20:42PM -0500, Kei Kebreau wrote:
Toggle quote (2 lines)
> * gnu/packages/chemistry.scm (spglib): New variable.

Thanks! LGTM

Toggle quote (10 lines)
> + #:phases
> + (modify-phases %standard-phases
> + (replace 'bootstrap
> + (lambda _
> + ;; These files are required by the Makefile, but not provided by
> + ;; the developers.
> + (for-each (lambda (file) (invoke "touch" file))
> + '("NEWS" "README" "AUTHORS"))
> + (invoke "autoreconf" "-vi"))))))

Can you file a bug upstream about this?
L
L
Leo Famulari wrote on 25 Jan 2021 23:18
Re: [bug#46107] [PATCH 3/6] gnu: Add molequeue.
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 46107@debbugs.gnu.org)
YA9Du+oYqLq1o8lf@jasmine.lan
On Mon, Jan 25, 2021 at 04:22:45PM -0500, Kei Kebreau wrote:
Toggle quote (6 lines)
> * gnu/packages/chemistry.scm (molequeue): New variable.

> + ;; TODO: Enable tests.
> + (arguments
> + '(#:tests? #f))

Can you clarify the comment? Even "It's too much work" would be helpful
for future readers.
L
L
Leo Famulari wrote on 25 Jan 2021 23:19
Re: [bug#46107] [PATCH 6/6] gnu: Add avogadro2.
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 46107@debbugs.gnu.org)
YA9D+ALFzV2vqq7z@jasmine.lan
On Mon, Jan 25, 2021 at 04:22:48PM -0500, Kei Kebreau wrote:
Toggle quote (2 lines)
> * gnu/packages/chemistry.scm (avogadro2): New variable.

Thanks a lot for taking care of this! I sent some other comments, but
they shouldn't block these patches.

LGTM
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAmAPQ/gACgkQJkb6MLrK
fwiiyBAApfJ8MXICKC6gftKW/9hQSIj2jHin1ndsG7p/mS0EqPwshCfvqAOpYiqL
cKQYVEiJprys9bPyLYSNRts+6pLGDI7RL9UCL/8qhCvzj8z8EKvyaQXQTVr7Aq8d
/aCwHM+B8DeXJivhIvi48nPPBH1HvbBDLvPSIfqfv5ZsmgSHaY/TRCBwoHnoqscZ
zHsjSN4g5diRgnWFu4AyAt5dOa4JVHVYUaHQPbYDwjRzVpP2aK/uf/lFe4T4QGCQ
6ISsnCKQKwc9LKfHY4tLRKDaoy7zKxQZU2siSiJ7L6wh1WiYNbwW4fx56CG7GjdC
dJbQy71AmOja8KYqr13RmbtT+dC86Yu7t5ziTbukwJIl7Lo8dyky+1gbTmgQVI4b
hvPXXvrzqHVz4kWuNUKJm4Q8599GNI7CLi9PQH+oxSvX5crTci142zKzv6qL0nMD
8mTBRKgDEuexDZGot1HF1G5f2vhndK86bStOTbQVwtq1a8NwgbB2UT/93jlPax/F
2SuDBjm1V/q+qz/VG9diLVaR6SUxP6uR/ei4f2mObLmbFwraYH/guA42QFwsYgpA
rPpSEwevHdx1w500CjOxWOzqYUr4n5WDUb/tzElzNS6snQMio+4JQ/JYwD6h9pK3
Mrewqcnyc8GjGyUdaIoUcP6TJszkMxwpGIoZnyAZbNcyB9uUqdo=
=JvZz
-----END PGP SIGNATURE-----


K
Re: [bug#46107] [PATCH 1/6] gnu: Add spglib.
(name . Leo Famulari)(address . leo@famulari.name)(address . 46107@debbugs.gnu.org)
1368650a601118e624c5dec06f7c35214de3a453.camel@posteo.net
On Mon, 2021-01-25 at 17:17 -0500, Leo Famulari wrote:
Toggle quote (18 lines)
> On Mon, Jan 25, 2021 at 04:20:42PM -0500, Kei Kebreau wrote:
> > * gnu/packages/chemistry.scm (spglib): New variable.
>
> Thanks! LGTM
>
> > + #:phases
> > + (modify-phases %standard-phases
> > + (replace 'bootstrap
> > + (lambda _
> > + ;; These files are required by the Makefile, but not provided
> > by
> > + ;; the developers.
> > + (for-each (lambda (file) (invoke "touch" file))
> > + '("NEWS" "README" "AUTHORS"))
> > + (invoke "autoreconf" "-vi"))))))
>
> Can you file a bug upstream about this?

On closer inspection, it seems that the developer is moving to make CMake the
main build system. Using the CMake build system, I ran into a known [0]
inconsistency [1] between the GNU and CMake build systems used by spglib. I've
patched spglib to deal with this for now, with links added in the comments.

K
Re: [bug#46107] [PATCH 3/6] gnu: Add molequeue.
(name . Leo Famulari)(address . leo@famulari.name)(address . 46107@debbugs.gnu.org)
e98c5374939d361ee3fa2d824e522345b2b98a8b.camel@posteo.net
On Mon, 2021-01-25 at 17:18 -0500, Leo Famulari wrote:
Toggle quote (9 lines)
> On Mon, Jan 25, 2021 at 04:22:45PM -0500, Kei Kebreau wrote:
> > * gnu/packages/chemistry.scm (molequeue): New variable.
> > + ;; TODO: Enable tests.
> > + (arguments
> > + '(#:tests? #f))
>
> Can you clarify the comment? Even "It's too much work" would be helpful
> for future readers.

While I was doing this, I went ahead and enabled all but the failing tests.
K
Re: [bug#46107] [PATCH 6/6] gnu: Add avogadro2.
(name . Leo Famulari)(address . leo@famulari.name)(address . 46107-done@debbugs.gnu.org)
a8e6d462d10b401808097c6b6c79685d8b76c340.camel@posteo.net
On Mon, 2021-01-25 at 17:19 -0500, Leo Famulari wrote:
Toggle quote (8 lines)
> On Mon, Jan 25, 2021 at 04:22:48PM -0500, Kei Kebreau wrote:
> > * gnu/packages/chemistry.scm (avogadro2): New variable.
>
> Thanks a lot for taking care of this! I sent some other comments, but
> they shouldn't block these patches.
>
> LGTM

Done and done! Thanks for reviewing and commenting. Avogadro is clear for
removal, especially since it doesn't seem to build anymore.
-----BEGIN PGP SIGNATURE-----

iQJIBAABCAAyFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAmAPi2wUHGtrZWJyZWF1
QHBvc3Rlby5uZXQACgkQ5qXuPBlGeg1N1RAAiBMgyca5APv8wXzw2MynLkzeoNpc
QRkGwfwdc72JYn3DM/bd5hKjOILpXw3a2j/sPon4lUUL1t3IL79JdX9CkHZFXeEA
uM5TrFDYAE0vutCEte42WegZsWkuPGDv5Z6XZkWOOHYUUPWAVSlFNj+8y2UWuKGU
RCXOZriQUU1J2EoV+Hs981e85+Yq4quTjZPREyqPMlabY9r1mLozOqICT3/gF+dC
d6F7ojntsji6ADTbXxdthgo837aTBhxRqUYyk+sY3XGG+Y2bAPFGvvQM+vwgaB1V
d2Hn6vC6OnYFLbp6UcUpmi1vjNAtM2k6EK/DzpdILpcfMDFSbqmaA1gzw7qEB0Zy
2WKeUbJNTckRVGOYiVBYf96GosjO+6OnRksOWZfufF8SWVoQ4Wi3aW4ASTyPzL1W
mX8XRls1T+sse4RTQ9NL2FnmWi1eMvxbAO5hcT8GIKYkCPANWep5RPvssXYpydFP
4aDvaG4HxH0oKGwYd9D0AnvhI2X47X2xJZjDHLOy4TcBT//gxhIwmZZYrwmqhY3z
2GcHQMTbtuzxGTFZNOApKS8eD6PAo04/N6383nZWHQmJ9T1lui/IEGrKUL0oBYHl
E5PkuwNLfef/mb7aQ6bNcl+IBepoBp2bL3ApOfLrfq+F4573xNgeQ5XVkhs1QdZO
y9Ab0fZJ4H1A0xE=
=+FuT
-----END PGP SIGNATURE-----


Closed
L
L
Leo Famulari wrote on 29 Jan 2021 02:05
(name . Kei)(address . kkebreau@posteo.net)(address . 46107-done@debbugs.gnu.org)
YBNfWJOg1qda1OsH@jasmine.lan
On Mon, Jan 25, 2021 at 10:24:28PM -0500, Kei wrote:
Toggle quote (3 lines)
> Done and done! Thanks for reviewing and commenting. Avogadro is clear for
> removal, especially since it doesn't seem to build anymore.

Do you know if avogradro2 is suitable as a "drop-in" replacement for
avogadro? If so, we could mark it as superseded by avogadro2, and then
it would be automatically updated in users' profiles when they do `guix
pull && guix upgrade`.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAmATX1UACgkQJkb6MLrK
fwjUhRAAgMxlACswKDzlR3ph7fCgB7VCN/IWOivmIlg/x/sEU0nvoufDXPhq2eoo
RKSxlLUmZkmeg3P4iznhc3Dt5/dunrL4pu/3C5rfEKEym6oqkmzUr95XQshhhtJW
wuDg9OYKFvggvR2oaWklsnl+Dsm0wwFTOZheIawA0gp+OA8H9+UlZV45PRltdzG1
bOaIXZBDlM3/Hkw0aXdWLY8wW3IY2Cje2YU+eEUPwPFzhXQfZEL8vqQZI8dsWnrm
i1UjN8TTB80ipCSrJleLI7QsGEvVAC02VLKa4PeAhT6/wFJNVnTtLZFoOuf2m0sN
gwD8uohsl62uaWNMaHpPhMvTv8Yk1QMrTmvCu31IDhf4kzXQ3zay5FHDo7n3XfkJ
pm4cgg/jLUQty/8Pd4w7gcX5lklo3SuA+9SYK3u3XkRORHGcI0cPnSDICFoWzt4t
CF7fylqCywQstsm52/qKazD8sJeZshGBviNpoUL14+68Z/Afg9Q9YltwMayXFVi8
bvLzfSQUqTeNkyJZp/dor60R28wyawJ+ueif+/rhI1RnO1PDur9LQ+BviLp/N+eu
Ln61GUg9rLH5FMjorX/g4Fvj11wvGeYGS2AoNAvv7D0E6ihz423UE1gnUwiaxEGR
Vy3d6Y5TchTt/gbMCzX+jf340p9meOIoXBiA17JiKlSSNFZEUvg=
=nmp4
-----END PGP SIGNATURE-----


Closed
K
K
kkebreau wrote on 29 Jan 2021 17:28
(name . Leo Famulari)(address . leo@famulari.name)(address . 46107-done@debbugs.gnu.org)
5d4c2474cdc539f2792e70b0dbcf7fc4@posteo.net
On 2021-01-28 20:05, Leo Famulari wrote:
Toggle quote (10 lines)
> On Mon, Jan 25, 2021 at 10:24:28PM -0500, Kei wrote:
>> Done and done! Thanks for reviewing and commenting. Avogadro is
>> clear for
>> removal, especially since it doesn't seem to build anymore.
>
> Do you know if avogradro2 is suitable as a "drop-in" replacement for
> avogadro? If so, we could mark it as superseded by avogadro2, and then
> it would be automatically updated in users' profiles when they do `guix
> pull && guix upgrade`.

I think so. Development efforts seem to have been focused on Avogadro 2
for
several years now, with little or no maintenance of the original
Avogadro. This
2018 community survey [0] indicates the developers' full commitment to
Avogadro 2, so marking it as superseding avogadro is recommended.

Closed
L
L
Leo Famulari wrote on 29 Jan 2021 21:20
(address . kkebreau@posteo.net)(address . 46107-done@debbugs.gnu.org)
YBRuB2sIfP090hgB@jasmine.lan
On Fri, Jan 29, 2021 at 11:28:08AM -0500, kkebreau@posteo.net wrote:
Toggle quote (6 lines)
> I think so. Development efforts seem to have been focused on Avogadro 2 for
> several years now, with little or no maintenance of the original Avogadro.
> This
> 2018 community survey [0] indicates the developers' full commitment to
> Avogadro 2, so marking it as superseding avogadro is recommended.

Since avogadro doesn't build, I decided to remove it rather than mark it
as superseded.

Removed with commit 42008264d9fff544ee00c3c109093472b8a92bd2
Closed
?