[PATCH] gnu: Add python-contexttimer.

  • Done
  • quality assurance status badge
Details
2 participants
  • nafkhamdc
  • Ricardo Wurmus
Owner
unassigned
Submitted by
nafkhamdc
Severity
normal
N
N
nafkhamdc wrote on 28 Mar 11:27 +0100
(address . guix-patches@gnu.org)(name . nafkhamdc)(address . navid.afkhami@mdc-berlin.de)
495145bd3f5d95dfd2e025496e161a8d5002c1f9.1711621671.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-contexttimer): New variable.

Change-Id: I1ed35f1d0190f0e3a60095c7627b6c17552cb4cc
---
gnu/packages/bioinformatics.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d18d5d8611..406506f549 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17575,6 +17575,28 @@ (define-public python-pyfaidx
fasta subsequences.")
(license license:bsd-3)))
+(define-public python-contexttimer
+ (package
+ (name "python-contexttimer")
+ (version "0.3.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/brouberol/contexttimer")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00a9h06a1wj66935n863qlk4jpl9gvdvzkkhl8xmgqwdkwv0js54"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-decorator python-unittest2))
+ (native-inputs (list python-mock))
+ (home-page "https://github.com/brouberol/contexttimer")
+ (synopsis "Timer as a context manager")
+ (description
+ "This package offers utilities to measure code block or function execution time.")
+ (license license:gpl3)))
+
(define-public python-cooler
(package
(name "python-cooler")

base-commit: 0e8f7ee3a95011dd9ebdc99e0f3b754160524b5d
prerequisite-patch-id: d26b189d1487d0d6a234a8197c5892f1e179e5f5
--
2.34.1
R
R
Ricardo Wurmus wrote on 28 Mar 13:31 +0100
(address . 70048-done@debbugs.gnu.org)
875xx6bkr1.fsf@elephly.net
Thanks for the patch. I applied it but moved it to python-xyz.scm, as
it is nothing to do with bioinformatics.

--
Ricardo
Closed
?