[PATCH] Add Jigmo, Plangothic, LXGW NeoZhiSong & HeartSerif

  • Done
  • quality assurance status badge
Details
2 participants
  • Zhu Zihao
  • ???
Owner
unassigned
Submitted by
Zhu Zihao
Severity
normal
Z
Z
Zhu Zihao wrote on 19 Apr 10:11 +0200
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
86y199bwjd.fsf@163.com
These patches attempt to add Jigmo, Plangothic, LXGW NeoZhiSong, LXGW
HeartSerif to Guix. Four fonts for Simplified Chinese.
--
Retrieve my PGP public key:

gpg --recv-keys B3EBC086AB0EBC0F45E0B4D433DB374BCEE4D9DC

Zihao
-----BEGIN PGP SIGNATURE-----

iIsEARYIADMWIQT4UAIrVkIEZilSHr2K2nJqP6LM8gUCZiInhhUcYWxsX2J1dF9s
YXN0QDE2My5jb20ACgkQitpyaj+izPKlwgD/TzXRnKoQyRM1p6VNbVy5Xx90Ph89
Wgq39ItkbvDG4wkBAMgJruhTu/ku3sMOr6VprR2auoafVHm89iAK89dVO4MB
=sRT9
-----END PGP SIGNATURE-----

Z
Z
Zhu Zihao wrote on 19 Apr 10:22 +0200
[PATCH 1/4] gnu: Add font-jigmo.
(address . 70470@debbugs.gnu.org)(name . Zhu Zihao)(address . all_but_last@163.com)
1ea43632596b5d28f13afdac3118ec0f1eaa32d4.1713514243.git.all_but_last@163.com
* gnu/packages/fonts.scm (font-jigmo): New variable.

Change-Id: Icdc619043d9f88eb413344fa9e7c2915ec86acc8
---
gnu/packages/fonts.scm | 22 +++++++++++++++++++++-
1 file changed, 21 insertions(+), 1 deletion(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 9ec722c19c..aa3783f228 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -34,7 +34,7 @@
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2020, 2021 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2020, 2024 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2020, 2021, 2022 Simen Endsjø <simendsjo@gmail.com>
;;; Copyright © 2020 Tim Van den Langenbergh <tmt_vdl@gmx.com>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
@@ -2963,6 +2963,26 @@ (define-public font-ipa-mj-mincho
to have a detailed and proper character style.")
(license license:ipa)))
+(define-public font-jigmo
+ (package
+ (name "font-jigmo")
+ (version "20230816")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://kamichikoichi.github.io/jigmo/Jigmo-"
+ version ".zip"))
+ (sha256
+ (base32 "1higvn4qvz25hx215fs2vqlzh2d2645jbxf07yd82y09drl429jd"))))
+ (build-system font-build-system)
+ (home-page "https://kamichikoichi.github.io/jigmo/")
+ (synopsis "The font contains most CJK unified ideograph characters")
+ (description "Jigmo is a font contains all CJK unified ideograph characters
+in Unicode 15.1 standard, ranges from CJK extension A to CJK extension I.
+It is generated by the font shape data in GlyphWiki using KAGE system, Clipper
+and FontForge.")
+ (license license:cc0)))
+
(define-public font-fontna-yasashisa-antique
(package
(name "font-fontna-yasashisa-antique")

base-commit: 2126dab4cd81db4cbde4566d8c638e45a4c0077c
--
2.41.0
Z
Z
Zhu Zihao wrote on 19 Apr 10:22 +0200
[PATCH 2/4] gnu: Add font-plangothic
(address . 70470@debbugs.gnu.org)(name . Zhu Zihao)(address . all_but_last@163.com)
498ae640a9bf1a1d8c1ce2b380a1502ce3228166.1713514243.git.all_but_last@163.com
* gnu/packages/fonts.scm (font-plangothic): New variable.

Change-Id: I5982af96057dbb7c354ebfa32c173b25cf883461
---
gnu/packages/fonts.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index aa3783f228..45515bbe78 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2983,6 +2983,36 @@ (define-public font-jigmo
and FontForge.")
(license license:cc0)))
+(define-public font-plangothic
+ (package
+ (name "font-plangothic")
+ (version "1.8.5760")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Fitzgerald-Porthmouth-Koenigsegg/"
+ "Plangothic-Project/releases/download/V"
+ version "/Plangothic.ttc"))
+ (sha256
+ (base32 "0ha2hcgy95ibmjk8lqfz0ihfc09swrzz3grlchma7qrwyxqbwpc0"))))
+ (build-system trivial-build-system)
+ (arguments
+ (list
+ #:modules '((guix build utils))
+ #:builder
+ #~(let* ((out #$output)
+ (dest (string-append out "/share/fonts/truetype")))
+ (use-modules (guix build utils))
+ (mkdir-p dest)
+ (copy-file #$(package-source this-package)
+ (string-append dest "/Plangothic.ttc")))))
+ (home-page
+ "https://github.com/Fitzgerald-Porthmouth-Koenigsegg/Plangothic-Project")
+ (synopsis "Sans font covers most CJK unified ideograph characters")
+ (description "Plangothic is a sans font based on Source Han Sans,
+modified to cover most CJK unified ideograph characters.")
+ (license license:silofl1.1)))
+
(define-public font-fontna-yasashisa-antique
(package
(name "font-fontna-yasashisa-antique")
--
2.41.0
Z
Z
Zhu Zihao wrote on 19 Apr 10:22 +0200
[PATCH 4/4] gnu: Add font-lxgw-heartserif
(address . 70470@debbugs.gnu.org)(name . Zhu Zihao)(address . all_but_last@163.com)
ab6271863ad208a4ade1b897ac66751005daad72.1713514243.git.all_but_last@163.com
* gnu/packages/fonts.scm (font-lxgw-heartserif): New variable.

Change-Id: I94cab117c35c536526e8f88d7ba05a3e6b5747d5
---
gnu/packages/fonts.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 5470a14f8e..b9f54ee6fa 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3466,6 +3466,36 @@ (define-public font-lxgw-neozhisong
Mainland China.")
(license license:ipa)))
+(define-public font-lxgw-heartserif
+ (package
+ (name "font-lxgw-heartserif")
+ (version "0.920.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/lxgw/LxgwNeoZhiSong/releases/download/v"
+ version "/LXGWHeartSerif.ttf"))
+ (sha256
+ (base32 "1nbhvy0b9vb0w5pfpp5f0jdkb6fs422avkdxzqydmv74g5v8gz07"))))
+ (build-system trivial-build-system)
+ (arguments
+ (list
+ #:modules '((guix build utils))
+ #:builder
+ #~(let ((out #$output)
+ (dest (string-append #$output "/share/fonts/truetype")))
+ (use-modules (guix build utils))
+ (mkdir-p dest)
+ (copy-file #$(package-source this-package)
+ (string-append dest "/LXGHeartSerif.ttf")))))
+ (home-page "https://github.com/lxgw/LxgwNeoZhiSong")
+ (synopsis "Simplified Chinese Song typeface derived from Kokoro Mincho")
+ (description "LXGW HeartSerif is a Simplified Chinese Song typeface derived
+from Kokoro Mincho, modified to adapt to the standard glyph shape used in
+Mainland China.")
+ (license license:ipa)))
+
(define-public font-chiron-sung-hk
(package
(name "font-chiron-sung-hk")
--
2.41.0
Z
Z
Zhu Zihao wrote on 19 Apr 10:22 +0200
[PATCH 3/4] gnu: Add font-lxgw-neozhisong
(address . 70470@debbugs.gnu.org)(name . Zhu Zihao)(address . all_but_last@163.com)
5660d95b17cec9ae65b78ecc3dae4ded88790720.1713514243.git.all_but_last@163.com
* gnu/packages/fonts.scm (font-lxgw-neozhisong): New variable.

Change-Id: I351bb86a22ad610f51d6e0e8aea290285529cbd3
---
gnu/packages/fonts.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 45515bbe78..5470a14f8e 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3436,6 +3436,36 @@ (define-public font-lxgw-wenkai-tc
Song typeface covering commonly used characters as well as written form of
dialects in Hong Kong and Taiwan.")))
+(define-public font-lxgw-neozhisong
+ (package
+ (name "font-lxgw-neozhisong")
+ (version "0.920.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/lxgw/LxgwNeoZhiSong/releases/download/v"
+ version "/LXGWNeoZhiSong.ttf"))
+ (sha256
+ (base32 "02jv5ysd450i47m3qmdwm3w23bp4wlqrjdwk6iirhgpv169p901j"))))
+ (build-system trivial-build-system)
+ (arguments
+ (list
+ #:modules '((guix build utils))
+ #:builder
+ #~(let ((out #$output)
+ (dest (string-append #$output "/share/fonts/truetype")))
+ (use-modules (guix build utils))
+ (mkdir-p dest)
+ (copy-file #$(package-source this-package)
+ (string-append dest "/LXGWNeoZhiSong.ttf")))))
+ (home-page "https://github.com/lxgw/LxgwNeoZhiSong")
+ (synopsis "Simplified Chinese Song typeface derived from IPAmj Mincho")
+ (description "LXGW NeoZhiSong is a Simplified Chinese Song typeface derived
+from IPAmj Mincho, modified to adapt to the standard glyph shape used in
+Mainland China.")
+ (license license:ipa)))
+
(define-public font-chiron-sung-hk
(package
(name "font-chiron-sung-hk")
--
2.41.0
?
Re: [bug#70470] [PATCH] Add Jigmo, Plangothic, LXGW NeoZhiSong & HeartSerif
(name . Zhu Zihao)(address . all_but_last@163.com)(address . 70470-done@debbugs.gnu.org)
87edb1v5xv.fsf@envs.net
Zhu Zihao <all_but_last@163.com> writes:

Toggle quote (3 lines)
> These patches attempt to add Jigmo, Plangothic, LXGW NeoZhiSong, LXGW
> HeartSerif to Guix. Four fonts for Simplified Chinese.

Pushed to master as commits cb31ea20ca..e9e60b3a1d, with change:
- Remove leading "The" in the synopsis of font-jigmo.

Thank you!
Closed
?