[PATCH] gnu: Add python-pyahocorasick.

  • Done
  • quality assurance status badge
Details
2 participants
  • nafkhamdc
  • Ricardo Wurmus
Owner
unassigned
Submitted by
nafkhamdc
Severity
normal
N
N
nafkhamdc wrote on 26 Apr 18:08 +0200
(address . guix-patches@gnu.org)(name . nafkhamdc)(address . navid.afkhami@mdc-berlin.de)
e0c540e55ea01ff0541ee02a324e6b40d329f6d1.1714147692.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-pyahocorasick): New variable.

Change-Id: I468bed450351b49cf81344a328841cd77f67cb4e
---
gnu/packages/bioinformatics.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index aa6bce5591..287dad4326 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6383,6 +6383,29 @@ (define-public python-pyani
average nucleotide identity.")
(license license:expat)))
+(define-public python-pyahocorasick
+ (package
+ (name "python-pyahocorasick")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/WojciechMula/pyahocorasick")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fsnivwcw56q7lwz41c5kbfvxv0v17mmkx43i2a293l49fxj08j8"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest python-twine python-wheel))
+ (home-page "https://github.com/WojciechMula/pyahocorasick")
+ (synopsis "Library for finding multiple key strings in text")
+ (description
+ "Pyahocorasick is a fast, memory-efficient library for multi-pattern string search.
+This means that you can find multiple key strings occurrences
+at once in some input text.")
+ (license license:bsd-3)))
+
(define-public exonerate
(package
(name "exonerate")

base-commit: 9593750698394b6fecd73e7fca00409ea1ffa2e3
--
2.34.1
R
R
Ricardo Wurmus wrote 43 hours ago
(address . 70595-done@debbugs.gnu.org)
87ikzrlxoc.fsf@elephly.net
Applied, thank you!

--
Ricardo
Closed
?