guix system search needs installer

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonathan Brielmaier
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
normal
J
J
Jonathan Brielmaier wrote on 4 Apr 2019 10:54
(address . bug-guix@gnu.org)
56dc9a78-a55c-a8a3-157c-327399784171@web.de
Hi,

during the use of the openSUSE package of Guix I found a little "bug".
Running "guix system search" results in:

guix system: warning: failed to load '(gnu system install)':
no code for module (gnu installer)

So I packaged guile-newt and configured the guix package with
"--enable-installer". Now this problem is gone :)

I just wonder if we should document this, so that it's clear
"--enable-installer" is not only needed for the installer. Or maybe
there is a way to remove the dependency for "guix system search" on (gnu
installer).

~Jonathan
L
L
Ludovic Courtès wrote on 4 Apr 2019 17:50
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 35138-done@debbugs.gnu.org)
875zrtsrap.fsf@gnu.org
Hi,

Jonathan Brielmaier <jonathan.brielmaier@web.de> skribis:

Toggle quote (6 lines)
> during the use of the openSUSE package of Guix I found a little "bug".
> Running "guix system search" results in:
>
> guix system: warning: failed to load '(gnu system install)':
> no code for module (gnu installer)

(Note that it’s a warning, not an error.)

I cannot reproduce this with a ‘guix’ coming from ‘guix pull’:

Toggle snippet (5 lines)
$ guix system search . > /dev/null
$ echo $?
0

Indeed, the problem came from the makefiles, and is fixed in commit
a7ad4505b7a09f32e2727a333e11716739efb713.

Thanks!

Ludo’.
Closed
J
J
Jonathan Brielmaier wrote on 12 Apr 2019 12:51
guix system search needs installer
(address . 35138@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
bb895813-d92b-3f93-e73b-33b35b0f5092@web.de
I think your fix in commit a7ad4505b7a09f32e2727a333e11716739efb713
introduced another bug.

So building guix now with "./configure --enable-installer" leads to this
error:
------------------------------------------------------------------
+ make clean
Makefile:5388: *** missing separator. Stop.
+ make -j8
Makefile:5388: *** missing separator. Stop.
------------------------------------------------------------------

The resulting Makefile looks as follow:
------------------------------------------------------------------
5384 scripts/guix: scripts/guix.in Makefile
5385 $(AM_V_at)rm -f $@ $@-t

5386 $(AM_V_at)$(MKDIR_P) "$(@D)"

5387 $(AM_V_GEN)$(do_subst) < "$(srcdir)/$@.in" > "$@-t"

5388 $(AM_V_at)chmod a+x,a-w "$@-t" && mv -f "$@-t" "$@"

5389 elif !ENABLE_INSTALLER

5390
------------------------------------------------------------------

My assumption is that the ENABLE_INSTALLER statement in gnu/local.mk
doesn't get evaluated "correctly".
------------------------------------------------------------------
621 # Always ship the installer modules but compile them only when

622 # ENABLE_INSTALLER is true.

623 if ENABLE_INSTALLER

624 GNU_SYSTEM_MODULES += $(INSTALLER_MODULES)

625 elif !ENABLE_INSTALLER

626 MODULES_NOT_COMPILED += $(INSTALLER_MODULES)

627 endif
------------------------------------------------------------------

With "./configure --disable-installer" the line 5389 in Makefile is
commented out.
L
L
Ludovic Courtès wrote on 12 Apr 2019 17:57
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 35138-done@debbugs.gnu.org)
877ebzp66j.fsf@gnu.org
Hello!

Jonathan Brielmaier <jonathan.brielmaier@web.de> skribis:

Toggle quote (25 lines)
> So building guix now with "./configure --enable-installer" leads to this
> error:
> ------------------------------------------------------------------
> + make clean
> Makefile:5388: *** missing separator. Stop.
> + make -j8
> Makefile:5388: *** missing separator. Stop.
> ------------------------------------------------------------------
>
> The resulting Makefile looks as follow:
> ------------------------------------------------------------------
> 5384 scripts/guix: scripts/guix.in Makefile
> 5385 $(AM_V_at)rm -f $@ $@-t
>
> 5386 $(AM_V_at)$(MKDIR_P) "$(@D)"
>
> 5387 $(AM_V_GEN)$(do_subst) < "$(srcdir)/$@.in" > "$@-t"
>
> 5388 $(AM_V_at)chmod a+x,a-w "$@-t" && mv -f "$@-t" "$@"
>
> 5389 elif !ENABLE_INSTALLER
>
> 5390
> ------------------------------------------------------------------

Oops, commit c8e070dad70cbc13b6f77d4f20d7d21d3931a835 should fix it.

Thanks for the report!

Ludo’.
Closed
?