'guix system switch-generation' does not reload Shepherd services

  • Open
  • quality assurance status badge
Details
2 participants
  • Brice Waegeneire
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
important
Merged with
L
L
Ludovic Courtès wrote on 3 Oct 2019 11:09
‘guix system roll-back’ doe sn’t reload services
(address . bug-Guix@gnu.org)
87wodmyz37.fsf@gnu.org
Hello,

‘guix system roll-back’ and ‘switch-generation’ don’t reload services
and don’t run activation scripts like ‘guix system reconfigure’ does.
Indeed:

Toggle snippet (12 lines)
(define (switch-to-system-generation store spec)
"Switch the system profile to the generation specified by SPEC, and
re-install bootloader with a configuration file that uses the specified system
generation as its default entry. STORE is an open connection to the store."
(let ((number (relative-generation-spec->number %system-profile spec)))
(if number
(begin
(reinstall-bootloader store number)
(switch-to-generation* %system-profile number))
(leave (G_ "cannot switch to system generation '~a'~%") spec))))

Ludo’.
L
L
Ludovic Courtès wrote on 6 Nov 2019 18:46
control message for bug #36855
(address . control@debbugs.gnu.org)
87woccvqxx.fsf@gnu.org
merge 36855 37596
quit
L
L
Ludovic Courtès wrote on 6 Nov 2019 18:46
(address . control@debbugs.gnu.org)
87v9rwvqxf.fsf@gnu.org
retitle 36855 'guix system switch-generation' does not reload Shepherd services
quit
L
L
Ludovic Courtès wrote on 6 Nov 2019 18:46
(address . control@debbugs.gnu.org)
87tv7gvqxa.fsf@gnu.org
severity 36855 important
quit
B
B
Brice Waegeneire wrote on 9 Mar 2021 08:01
Re: bug#37596: 'guix system switch-generation' does not reload Shepherd services
(name . Robert Vollmert)(address . rob@vllmrt.net)
877dmgzu7l.fsf@waegenei.re
Hello Guix,

To summarise the whole thread, in addition to the main issue explained
in the title “'guix system switch-generation' does not reload Shepherd
services“ there are 2 other issues talked about.

1. The activation script isn't executed by 'guix system
switch-generation', which is fixed in
df138dc20858725b90ed77be85f3318cbe1be73a and later.
2. The activation process isn't exclusivly build during the system
building process, whihc may the leave the system in half-hazard state
if the building taking place during the activation fail.

The second side issue should proablby have it's own bug report since
it's still present and we should keep that bug report only for the lack
of reloading of shepherd service when using 'guix system
switch-generation' (or 'roll-back').

Cheers,
- Brice
?