Org Mode is borked

  • Done
  • quality assurance status badge
Details
2 participants
  • Diego Nicola Barbato
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Diego Nicola Barbato
Severity
normal
D
D
Diego Nicola Barbato wrote on 3 Dec 2019 23:59
(address . bug-guix@gnu.org)
87v9qxc8xc.fsf@GlaDOS.home
Hi Guix,

Our Org Mode package (emacs-org) seems to be broken in a funny way.
Here's how to reproduce this bug (on commit dac7928):

1) Install ‘emacs’ and ‘emacs-org’.
2) Start Emacs and work around https://debbugs.gnu.org/38399by adding
the directory containing org to the front of ‘load-path’:
--8<---------------cut here---------------start------------->8---
(push "/path/to/org-9.2.6" load-path)
--8<---------------cut here---------------end--------------->8---
3) Open a new org file:
--8<---------------cut here---------------start------------->8---
C-x C-f foo.org RET
--8<---------------cut here---------------end--------------->8---
4) Enter the following text into the buffer:
--8<---------------cut here---------------start------------->8---
#+STARTUP: indent
--8<---------------cut here---------------end--------------->8---
5) Verify you're running Org Mode version 9.2.6 by running:
--8<---------------cut here---------------start------------->8---
M-x org-version RET
--8<---------------cut here---------------end--------------->8---
6) Here comes the fun part: Hit C-c C-c. This will produce the
following error message:
--8<---------------cut here---------------start------------->8---
Symbol’s function definition is void: org-outline-overlay-data
--8<---------------cut here---------------end--------------->8---
7) Now reload Org from source (instead of the .elc files):
--8<---------------cut here---------------start------------->8---
C-u C-c C-x !
--8<---------------cut here---------------end--------------->8---
6) Repeat step 6. This time it succeeds!
--8<---------------cut here---------------start------------->8---
Local setup has been refreshed
--8<---------------cut here---------------end--------------->8---

The function ‘org-outline-overlay-data’ isn't defined anywhere in the
org-9.2.6 source, but it is defined in the org bundled with Emacs.
Because of this I suspect that the new emacs-build-system generates a
weird chimera containing parts of both org-9.2.6 and org-9.1.9.

To my untrained eye this looks like it’s probably a consequence of the
aforementioned bug #38399. So I'd expect this issue to disappear as
soon as that one is fixed.

Regards,

Diego
M
M
Maxim Cournoyer wrote on 8 Dec 2019 04:37
(name . Diego Nicola Barbato)(address . dnbarbato@posteo.de)(address . 38479-done@debbugs.gnu.org)
87h82bqygy.fsf@gmail.com
Hello Diego!

Diego Nicola Barbato <dnbarbato@posteo.de> writes:

Toggle quote (39 lines)
> Hi Guix,
>
> Our Org Mode package (emacs-org) seems to be broken in a funny way.
> Here's how to reproduce this bug (on commit dac7928):
>
> 1) Install ‘emacs’ and ‘emacs-org’.
> 2) Start Emacs and work around https://debbugs.gnu.org/38399 by adding
> the directory containing org to the front of ‘load-path’:
> --8<---------------cut here---------------start------------->8---
> (push "/path/to/org-9.2.6" load-path)
> --8<---------------cut here---------------end--------------->8---
> 3) Open a new org file:
> --8<---------------cut here---------------start------------->8---
> C-x C-f foo.org RET
> --8<---------------cut here---------------end--------------->8---
> 4) Enter the following text into the buffer:
> --8<---------------cut here---------------start------------->8---
>
> #+STARTUP: indent
> --8<---------------cut here---------------end--------------->8---
>
> 5) Verify you're running Org Mode version 9.2.6 by running:
> --8<---------------cut here---------------start------------->8---
> M-x org-version RET
> --8<---------------cut here---------------end--------------->8---
> 6) Here comes the fun part: Hit C-c C-c. This will produce the
> following error message:
> --8<---------------cut here---------------start------------->8---
> Symbol’s function definition is void: org-outline-overlay-data
> --8<---------------cut here---------------end--------------->8---
> 7) Now reload Org from source (instead of the .elc files):
> --8<---------------cut here---------------start------------->8---
> C-u C-c C-x !
> --8<---------------cut here---------------end--------------->8---
> 6) Repeat step 6. This time it succeeds!
> --8<---------------cut here---------------start------------->8---
> Local setup has been refreshed
> --8<---------------cut here---------------end--------------->8---

I could reproduce (and fix :-)) this problem.

The solution was to *prepend* instead of appending the source directory of the software being
compiled to EMACSLOADPATH, in the 'add-source-to-load-path phase of the
Emacs build system.

Pushed to master with commit add773c37a10e2c900fcfaff745e095b7fe96fbb.

Thank you for the report and reproduction steps.

Maxim
Closed
?