Add font-meera-inimai

  • Done
  • quality assurance status badge
Details
One participant
  • Arun Isaac
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 31 Mar 2020 11:58
(address . guix-patches@gnu.org)
cu7wo70lubg.fsf@systemreboot.net
The attached patchset adds font-meera-inimai.
From dbf3a6d680e8c835396861a941da58fdabf09ef0 Mon Sep 17 00:00:00 2001
From: Arun Isaac <arunisaac@systemreboot.net>
Date: Tue, 31 Mar 2020 15:09:01 +0530
Subject: [PATCH 1/2] gnu: Add python-google-brotli.

* gnu/packages/compression.scm (python-google-brotli): New variable.
---
gnu/packages/compression.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 2e1fe04dde..9ff3a77b1e 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,6 +51,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages assembly)
@@ -1851,6 +1853,17 @@ The specification of the Brotli Compressed Data Format is defined in RFC 7932.")
;; We used to provide an older version under the name "brotli".
(deprecated-package "brotli" google-brotli))
+(define-public python-google-brotli
+ (package
+ (inherit google-brotli)
+ (name "python-google-brotli")
+ (build-system python-build-system)
+ (arguments '())
+ (synopsis "Python interface to google-brotli")
+ (description "@code{python-google-brotli} provides a Python interface to
+@code{google-brotli}, an implementation of the Brotli lossless compression
+algorithm.")))
+
(define-public ucl
(package
(name "ucl")
--
2.26.0
From ae40c5002f9074e1c784fc42ff8474bd1cdb2d36 Mon Sep 17 00:00:00 2001
From: Arun Isaac <arunisaac@systemreboot.net>
Date: Tue, 31 Mar 2020 15:10:12 +0530
Subject: [PATCH 2/2] gnu: Add font-meera-inimai.

* gnu/packages/fonts.scm (font-meera-inimai): New variable.
---
gnu/packages/fonts.scm | 44 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 43 insertions(+), 1 deletion(-)

Toggle diff (71 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 527f2cbbd6..08d49ac687 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Brendan Tildesley <mail@brendan.scot>
-;;; Copyright © 2017, 2018, 2019 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2018, 2019, 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Mohammed Sadiq <sadiq@sadiqpk.org>
;;; Copyright © 2018 Charlie Ritter <chewzerita@posteo.net>
;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
@@ -63,9 +63,11 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages xorg))
(define-public font-ibm-plex
@@ -1626,3 +1628,43 @@ always uses Farsi digits, and does not include Latin glyphs from Roboto.
(license:x11-style ; ...the Bitstream Vera typeface
"file://LICENSE" "Bitstream Vera License")
license:asl2.0)))) ; Latin glyphs from Roboto
+
+(define-public font-meera-inimai
+ (package
+ (name "font-meera-inimai")
+ (version "2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/smc/meera-inimai")
+ (commit "0f39cdd7dbf1b6d1bed7df85834d33789dce20a7")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1x5mhrpx24imh0r4l83mkaiszxgwi1q4ppyyvq63h3ddwk20cwdg"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("fontforge" ,fontforge)
+ ("harfbuzz" ,harfbuzz "bin")
+ ("python" ,python-minimal)
+ ("python-fonttools" ,python-fonttools)
+ ("python-google-brotli" ,python-google-brotli)))
+ (arguments
+ `(#:make-flags (list "PY=python3"
+ (string-append "DESTDIR=" %output)
+ "fontpath=/share/fonts/truetype")
+ #:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://gitlab.com/smc/meera-inimai")
+ (synopsis "Meera Inimai Tamil font")
+ (description "Meera Inimai is a Unicode font for the Tamil Script. Meera
+Inimai is a san-serif typeface. It is best used as a screen font for body
+text. It is also useful for body text of printed pamphlets or single page
+designs. Meera Inimai can be thought of as similar to Helvetica and its
+variation Arial. Tamil characters are inherently vertically-elliptical. The
+orthography of Roman glyphs of Meera Inimai are also based on this
+characteristic so that they sit smoothly with the Tamil glyphs.")
+ (license license:silofl1.1)))
--
2.26.0
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl6DFEQACgkQLiXui2GA
K7M5agf/a/FBa6u1ryPlwfdfjyS2KHVYvf1zmkZgXjvVYiTJcZfexLJgUzZyEDYd
KgubT3htzjM3pMGHLxS/oEUWMiyDIKt4OWNn/1+fXvENmTZ41sqGWAvy6WUfq1iY
FHvYSO45a4mnnidq7v5kHee01mCJ4fo0H/+VwxfjtwhgkV7E/UkW/XhaDuoYyQQL
pGZS0fNe1nHPWH0QnVEXGNE5DfUhLQD/ot4EFyhwb0hCofkVIDBj+2XeA1iIbsCK
agBDPOEpdWoFD5oxVoOkpSKT3vE1k8v6x8DCaYXz3+eOja53T3GJ2zJEQQjXmWgM
3k5CycJMiesNFVy4hogkVxDYwz/wiA==
=IXr1
-----END PGP SIGNATURE-----

A
A
Arun Isaac wrote on 22 Apr 2020 06:42
(address . 40345-done@debbugs.gnu.org)
cu74ktct9ku.fsf@systemreboot.net
Pushed to master!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl6fy0EACgkQLiXui2GA
K7MZaQgAtPT8UfrdJnNwZBG+cE7FYbAAxf72MSXO2TEi4iySEUIfnAdUpY6N6XOz
1EZ71mGlfQn4tBC2jAXaxou1Hkn9Ks0npHTnXblqvG3Ro02ZgAIS2KvjkFfIFfzy
47GlNywnB18ADytOLUkcgR91F3/ZovYeQ2Y4kyP2ufoVTyNYvwbfyurxFvrcyRQ+
IkZCiEy2JkjLa+KY1iApjjtUmV7AIqtInU3paUaKGr8yHbSzxhcvymy3T0emyDvt
MnjUrBgQEoRkafJpNEeew0jieW5Xq/bBMXIPW9MKte+HAtAr/G6QN3eX+Oiwd9v+
r5TT3MWPpSDDGQyXFD3TuirBP80i8A==
=IvZn
-----END PGP SIGNATURE-----

Closed
?