"make check" fails: "guix package: error: socket: Protocol not supported"

  • Done
  • quality assurance status badge
Details
3 participants
  • Chris Marusich
  • Ludovic Courtès
  • Mark H Weaver
Owner
unassigned
Submitted by
Chris Marusich
Severity
normal
Merged with
C
C
Chris Marusich wrote on 14 Nov 2015 21:31
(address . bug-guix@gnu.org)
CAEKzfHn2MdtTAYUVRAoihSPkk4v71npdGDK0oC5ZgL5DBQ_X4A@mail.gmail.com
2abcc93
L
L
Ludovic Courtès wrote on 14 Nov 2015 22:52
control message for bug #21925
(address . control@debbugs.gnu.org)
878u60uu3j.fsf@gnu.org
merge 21925 21924
L
L
Ludovic Courtès wrote on 16 Nov 2015 17:44
Re: bug#21925: Additional information for bug report: 21925
(name . Chris Marusich)(address . cmmarusich@gmail.com)
87wpth3nd1.fsf@gnu.org
Chris Marusich <cmmarusich@gmail.com> skribis:

Toggle quote (9 lines)
> I've noticed that I also experience similar failures when I try to
> install certain packages. For example, I cannot install ncurses or
> autoconf:
>
> marusich@garuda ~$ guix package -i autoconf
> guix package: error: socket: Protocol not supported
> marusich@garuda ~$ guix package -i ncurses
> guix package: error: socket: Protocol not supported

Could you apply this patch:
Toggle diff (16 lines)
diff --git a/guix/ftp-client.scm b/guix/ftp-client.scm
index f02d460..e76f08a 100644
--- a/guix/ftp-client.scm
+++ b/guix/ftp-client.scm
@@ -140,8 +140,9 @@ TIMEOUT, an ETIMEDOUT error is raised."
(let loop ((addresses addresses))
(let* ((ai (car addresses))
- (s (socket (addrinfo:fam ai) SOCK_STREAM ;TCP only
- (addrinfo:protocol ai))))
+ (s (socket (addrinfo:fam ai)
+ ;; TCP/IP only
+ SOCK_STREAM IPPROTO_IP)))
(catch 'system-error
(lambda ()
and then try again, with:

./pre-inst-env guix package -i autoconf

(I can provided more info on how to apply the patch if needed. See also

This may be a regression introduced in 279ec1d.

TIA!

Ludo’.
L
L
Ludovic Courtès wrote on 17 Nov 2015 09:46
(name . Chris Marusich)(address . cmmarusich@gmail.com)
87y4dx9fot.fsf@gnu.org
Chris Marusich <cmmarusich@gmail.com> skribis:

Toggle quote (8 lines)
>> Could you apply this patch
>
> The patch fixes the problem for me. Now, all the tests run during
> "make check" succeed, and when I ran the following command, it worked
> as expected:
>
> ./pre-inst-env guix package -i autoconf

OK, pushed as b7f4677.

Thank you for testing!

Ludo’.
Closed
M
M
Mark H Weaver wrote on 17 Nov 2015 15:27
Re: bug#21924: "make check" fails: "guix package: error: socket: Protocol not supported"
(name . Chris Marusich)(address . cmmarusich@gmail.com)
87y4dw7lc9.fsf@netris.org
close 21924
thanks

Chris Marusich <cmmarusich@gmail.com> writes:
Toggle quote (2 lines)
> 2abcc93

This was a failed first attempt to report the same bug as
http://bugs.gnu.org/21925. Closing this one.

Thanks,
Mark
?