[PATCH 2/6] services: pulseaudio-service-type: Honor /etc.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Marius Bakke
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal
Merged with
L
L
Leo Prikler wrote on 10 Jan 2020 02:48
(address . guix-patches@gnu.org)(address . 39053@debbugs.gnu.org)
20200110014823.10595-2-leo.prikler@student.tugraz.at
* gnu/services/sound (pulseaudio-environment): Add PULSE_CONFIG and
PULSE_CLIENTCONFIG.
---
gnu/services/sound.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/services/sound.scm b/gnu/services/sound.scm
index 307e62fd1b..6b2b345a44 100644
--- a/gnu/services/sound.scm
+++ b/gnu/services/sound.scm
@@ -123,8 +123,10 @@ ctl.!default {
(define (pulseaudio-environment config)
;; Define this variable in the global environment such that
;; pulseaudio swh-plugins works.
- `(("LADSPA_PATH"
- . ,(file-append swh-plugins "/lib/ladspa"))))
+ `(("LADSPA_PATH" . ,(file-append swh-plugins "/lib/ladspa"))
+ ;; Define these variables, so that pulseaudio honors /etc.
+ ("PULSE_CONFIG" . "/etc/pulse/daemon.conf")
+ ("PULSE_CLIENTCONFIG" . "/etc/pulse/client.conf")))
(define (pulseaudio-conf-entry arg)
(match arg
--
2.24.1
M
M
Marius Bakke wrote on 11 Jan 2020 17:54
(address . control@debbugs.gnu.org)
87v9piyluy.fsf@devup.no
merge 39053 39052 39054 39055 39062 39061 39063 39065 39064
thanks
M
M
Marius Bakke wrote on 11 Jan 2020 17:57
(address . 39053@debbugs.gnu.org)
87tv52ylpn.fsf@devup.no
Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (21 lines)
> * gnu/services/sound (pulseaudio-environment): Add PULSE_CONFIG and
> PULSE_CLIENTCONFIG.
> ---
> gnu/services/sound.scm | 6 ++++--
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/services/sound.scm b/gnu/services/sound.scm
> index 307e62fd1b..6b2b345a44 100644
> --- a/gnu/services/sound.scm
> +++ b/gnu/services/sound.scm
> @@ -123,8 +123,10 @@ ctl.!default {
> (define (pulseaudio-environment config)
> ;; Define this variable in the global environment such that
> ;; pulseaudio swh-plugins works.
> - `(("LADSPA_PATH"
> - . ,(file-append swh-plugins "/lib/ladspa"))))
> + `(("LADSPA_PATH" . ,(file-append swh-plugins "/lib/ladspa"))
> + ;; Define these variables, so that pulseaudio honors /etc.
> + ("PULSE_CONFIG" . "/etc/pulse/daemon.conf")
> + ("PULSE_CLIENTCONFIG" . "/etc/pulse/client.conf")))

I squashed this with the first patch.

By the way, for future merge request, please open a single bug report
and send all patches to NNNNN@debbugs.gnu.org. I've merged the bugs
opened by this series.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl4Z/pQACgkQoqBt8qM6
VPr65QgAibs8txfpQzOe7wBwdBG0otBy8u5wjlt9uRd+OJXYHbHmBN7b0LvCT8Sr
7v1h8sQIeqygaqBwsFBoBl90ZzKzrdDIrExaGXVnn3T287Pjrk2FYd/Yi1uWRU15
vHDG3DlLT3ep5VCAKkBnQplqx0o6OUvS1/Tp+W/iKhvn9yAxv61LcEEIcYg3Ve3r
PWNpzJHNoNGd/u/HJWa3qdozT+MBk0aFhfMTWA2drwifhkxUjBJ52cgyGW+z5R5L
m7Q5ftKLiox54fQSsNFuuNUGd4/IVkSgO5w02+orEAmRtedO/jajNlVLuqAFvhbu
sh+LfOz6XC9dDGdS7H60aoikH+8wBA==
=7qYN
-----END PGP SIGNATURE-----

?